Blog Informático

Del Perú Pal’ Mundo

Usar Internet Explorer en Linux

Posted by al93 en Jueves 19 junio, 2008

Bien, cuando yo usaba gutsy tenia instalado el ie para usarlo en aquellas webs en las que firefox no funciona…

Cuando me pase a Hardy… no se si por pereza o por cuestiones de que no usaba mucho el IE no lo quize instalar… pero justo hoy se me presento un problema con el firefox en algunas webs asi que procedi a instalarlo… sin embargo encontre un error (mas bien una desactualizacion)

Lo que vamos hacer es instalar Wine (Windows Emulator) para luego poder usar el ie…

1. Abre la consola y escribe:

  • Para Gutsy Gibbon:

sudo wget http://wine.budgetdedicated.com/apt/sources.list.d/gutsy.list -O /etc/apt/sources.list.d/winehq.list

  • Para Hardy Heron:

sudo wget http://wine.budgetdedicated.com/apt/sources.list.d/hardy.list -O /etc/apt/sources.list.d/winehq.list

2. Actualiza los repositorios:

sudo aptitude update

3. Instala Wine:

sudo apt-get install wine

4. Descarga este archivo, descomprimirlo y ejecutar ies4linux

Aparecerá esta pantalla:

En Advanced, se mostrará la siguiente pantalla, que permite cambiar la dirección de la instalación:

Luego mostrará la siguiente pantalla donde se ve el proceso y al final dará la dirección donde podemos encontrar el ejecutable del ie (que no es más que la dirección que figura en Advanced seguida de /ie6)

Bueno, la “actualización” de la que hablaba al inicio está en que en tuxpepino solo figura la dirección para Gutsy, en la web de Wine ya pueden encontrar la que figura en este post… para Hardy

Un saludo,

Al93

5 comentarios to “Usar Internet Explorer en Linux”

  1. Nienna said

    Hola, he intentado instalar el ies4linux en una kubuntu, y como he leido que necesitaba el wine me lo he instalado también. Así que tengo la última versión de ambos programas. La del wine es la 1.0 parece que han llegado a una versión estable. Pues cual ha sido mi sorpresa cuando al empezar a instalar el ies4linux me ha salido un mensaje de error, quejandose de que mi versión del wine es antigua. Chistoso él dice que 1.0 es más antiguo que 0.9.x, ¿sugerencias?

    Pego aquí el error que me sale:
    ./ies4linux
    IEs4Linux esta pensado para ser usado con versiones recientes de Wine (0.9.x). Parece que esta usando una versión antigua (wine-1.0). Es recomendable que actualice a la ultima versión de Wine (Vaya a: winehq.com).

    No hay interfaz grafica disponible. Use IEs4Linux en linea de comandos o instale ‘pygtk’. Para mas detalle: http://www.tatanka.com.br/ies4linux/page/No_GUI

    IEs4Linux esta pensado para ser usado con versiones recientes de Wine (0.9.x). Parece que esta usando una versión antigua (wine-1.0). Es recomendable que actualice a la ultima versión de Wine (Vaya a: winehq.com).

    Usage: ./ies4linux [OPTIONS]

    This script downloads and automagically installs multiple versions of
    Microsoft Internet Explorer on Wine.

    Without any option, IEs4Linux will:
    – install IE6
    – install Adobe Flash 9
    – create icons on Desktop and Menu
    – use folder: /home/rocio/.ies4linux

    You can configure other things:

    –install-ie55 Install IE5.5 in BASEDIR/ie55/
    –install-ie5 Install IE5 in BASEDIR/ie5/

    –install-corefonts Install MS Core Fonts (corefonts.sf.net)

    –no-flash Don’t install Adobe Flash Player 9
    –no-ie6 Don’t install IE 6

    –no-desktop-icon Don’t create an icon in Desktop
    –no-menu-icon Don’t insert icon on Menu

    –full-help Display all possible options

    ¿Cómo soluciono esto?¿Y si no se puede, existen más emuladores de IE para firefox? No es que me apasione el IE más bien lo odio, pero cuando uno tiene que desarrollar una Web no le queda otra. ¿Tengo que acabar muriendo a una máquina virtual?

    Nienna.

  2. Nienna said

    Buenas,
    Ya está solucionado por si a alguién más le pasa.

    Basta con comentar la linea 36 del fichero lib/functions.sh:

    wine –version 2>&1 | grep -q “0.9.x” || warning $MSG_WARNING_OLDWINE

    o substituir el grep por una expresión que busque tanto las versiones 0.9.x como las 1.x.

    Espero que os sirva
    Nienna

  3. al93 said

    a todo esto… que versión de kubuntu tienes?

  4. franky said

    Esa es la solución para amantes del grep , es más fácil poner

    ./ies4linux –no-gui

    Con eso te ahorra lo del pygtk y el warning ese de la versión de wine

  5. SelahX said

    Gracias Franky, llevaba más de dos horas con el mismo error, pero con la istrucción que pusiste, quedó perfecto.

Responder

Introduce tus datos o haz clic en un icono para iniciar sesión:

Logo de WordPress.com

Estás comentando usando tu cuenta de WordPress.com. Cerrar sesión / Cambiar )

Imagen de Twitter

Estás comentando usando tu cuenta de Twitter. Cerrar sesión / Cambiar )

Foto de Facebook

Estás comentando usando tu cuenta de Facebook. Cerrar sesión / Cambiar )

Google+ photo

Estás comentando usando tu cuenta de Google+. Cerrar sesión / Cambiar )

Conectando a %s

 
A %d blogueros les gusta esto: